Berikut akan saya sampaikan topik tentang Multiple Web Server di belakang mikrotik

Setting ini bukan murni dari penulis tetapi dari hasil membaca di salah satu website dan sudah saya praktekkan dilapangan.

Tips Langkah Setting Multiple Web Server di belakang mikrotik

Sebelum dibahas tentang setting multiple web server dibelakang mikrotik ini sebelumnya ada syarat yang harus dipenuhi, yaitu :

1. ISP anda memiliki IP static supaya lebih mudah untuk setting

2. Bandwith internet memadai, cek kecepatan internet anda di speedtest.net

Cek kecepatan internet anda di speedtest.net

Cek kecepatan internet anda di speedtest.net

Apabila kecepatan internet anda sudah memadai segera kita mulai langkah Multiple Web Server di belakang mikrotik.

Dalam kasus ini ada 3 web server di belakang mikrotik :

website1.com dst-address to IP komputer 192.168.1.2
website2.com dst-address to IP komputer 192.168.1.3
website3.com dst-address to IP komputer 192.168.1.4

1. Configure web proxy

/ip web-proxy 
set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \ 
transparent-proxy=yes parent-proxy=0.0.0.0:0 \ 
cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \ 
max-cache-size=unlimited max-ram-cache-size=unlimited 
/ip web-proxy access 
add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \ 
disabled=no 
add dst-port=80 action=allow comment="Enable Http Connection" disabled=no 

2. Configure Static DNS of domains to resolve to internal ip

/ip dns static add name=website1.com address=192.168.1.2 
/ip dns static add name=website2.com address=192.168.1.3 
/ip dns static add name=website3.com address=192.168.1.4 
/ip dns static add name=www.website1.com address=192.168.1.2 
/ip dns static add name=www.website2.com address=192.168.1.3 
/ip dns static add name=www.website3.com address=192.168.1.4 

3. Configure NAT to redirect traffic to webproxy

/ip firewall nat 
add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \ 
dst-port=80 action=redirect to-ports=8080 comment="" disabled=no 

Untuk keamanan proses terakhir adalah :

/ip proxy access 
add dst-port=80 dst-host="website1.com" action=allow disabled=no
add dst-port=80 dst-host="website2.com" action=allow disabled=no
add dst-port=80 dst-host="website3.com" action=allow disabled=no
add action=deny disabled=no

Apabila dengan langkah tersebut diatas ternyata belum dapat diakses, cobalah cek setting firewal di web server anda.

 

Sumber : wiki.mikrotik.com